formatting partition

ok, I have a mygig harddrive. I run this command dinit -h /dev/umass0t80 i get this error dinit - block 0: invalid argument

Maybe try the dinit command without the -h since you are attempting to format a USB drive which isn’t what -h is for (Compact Flash/HD).


Can you use’ fdisk /dev/umass0’ successfully?

BTW “80” is not a QNX partition type - though it is not relevant to the failure.

thanks for your replies I will try with out the -h. yes I can fdisk umass0, but I have do -z. I know 80 is not qnx but that is what all the howto’s tell me to do, however in linux fdisk list the partation as 50. and the howto’s said to do dinit -h

I’d suggest two tests.

Your comment that you need to use -z suggests a problem.
Do you need -z each time you run dinit?
You should only need to use it once, that is if it worked the first time.

To do more evaluation, I suggest the following:

  1. Run check on the drive, see if dcheck can read the sectors.

  2. Run spatch on the disk. Edit and save data on the first sector and quit.
    Then run spatch again to see if the data was saved.

While most USB drives work fine with QNX 6.5, there are some that cause problems.
If this drive is not working, I suggest trying another.

ok, I will try these test this evening. I have to use -z option with fdisk or it doesn’t work. It is a good possibility both drives I am trying this on are bad.

You have to use -z because the partition table signature is likely bad. However, you are clearly not able to write to the disk to correct it. Can you write to the disk from Linux or Windows? Maybe the hardware is bad?

in linux fdisk list the partation as 50
50h is 80 decimal.

ok, i ran some of those commands and it seems to be fine, no errors…now I can do fdisk /dev/umass0 without the -z. however the dinit -h gave me the same error, Yes I read the options -h is to initialize a hard drive, it is a harddrive hooked to usb. I am downloading a drive tester i suspect either the harddrive has some bad sectors of the usb controller is crapped out. i had used this drive for bootcamp(Mac0s) of windows 8.

western digitial diag finds no faults on the quick test

Maybe the drive has 4K sectors? If so, you need to put it in 512-byte sector emulation mode.

i have to figure out how to tell if it is 4k sectors. the only reason I am doing this is because the orginal harddrive’s 4th partition contains mp3s, for some reason they quit displaying on the headunit and I cannot add new files, the other partitions contain mapdata which still works. when i plug that drive into qnx the 4th partition does not show up. I used clonezilla and copied it to the new harddrive. Sometimes when I boot qnx with the drive attached all 4 parts show up as /fs/hd010-qnx4-1 thru 4 so i drill down thru the 4th part and lo and behold there are my mp3’s from orginal drive. but once i mess around in it the part disappears and each other part disappears as i access them. I then disconnect and reconnect the usb drive, now they become /dev/umass0t77 thru 80

no help?

i tried mount -t80 /dev/hd1t80 -t50 /disk
mount: can’t mount / (type nonqnx)
mount: possible reason : can’t access shared library

i tried mount -t80 /dev/hd1t80 -t50 /disk

mount -tqnx4 /dev/hd1t80 /disk

The -t option to mount must resolve to the name of a dll as in “”.

so…the fix?

One solution would be to number the partition 77, 78 or 79.

The partitions - which mount initially - are “magically” unmounted when corruption is detected. You can run ‘chkfsys’ against an unmounted qnx4 partition to attempt to fix errors.

still nothing? bah its not QNx’s fault its the idiots at Harmon Becker, why the hell did they use t50 for music partition? couldnt they used ext3 or what the heck maybe the qnx fs? lately I have just been using the cd rom on it. I cant even contact anyone at HB the give a rip

I have determined that write fail was the usb adapter. I purchased another one and I am able to run the dinit command on it. I am still unable to “fix” this because I am suppose to copy the files onto that 4th partition which qnx cannot read…once again, thanks harmon becker for screwing this up