sysinfo utility

Hi all,

I have executed the sysinfo command. But it is not working in my QNX 6.5.0 machine. Could you please tell me the reason?
Is there any other alternative so that I can get some information about my QNX machine? Also I would like to know the cache
size, number of processors, RAM size, frequency etc.
I have yet another doubt. When I run the QNX OS on a Pentium 4 machine, the System Monitor is showing 2 CPUs. Also when I check the same under an Intel Xeon machine(dual core), system monitor is showing 2 CPUs. When I check it under a Quad Core PC, the system monitor is showing 8 CPUs. I am confused with this. Could you please share your thoughts on this?


Have you tried ‘pidin info’? It shows you the QNX version, free/max memory and lists the processors along with their operating frequency. I’m not sure about cache size but with the information you get from pidin info about the processor you should be able to look that up online.

As far as Quad-Core processors showing up as 8 CPUs, this is apparently due to hyper-threading and is not limited to QNX. … of-4-cores

It’s better if you turn off Hyperthreading in the BIOS.

QNX will treat those as real CPU’s and schedule there accordingly when they are no where near as fast as a true core. This can cause your algorithms to jitter and miss schedules…


Hi all,

As you said, I have checked if Hyperthreading is enabled in BIOS. But it is already disabled in my Quad core PC. But some other technologies like Intel Virtualization, Intel SpeedStep, C-State are enabled. Could you please tell if any of these causes QNX system to detect the number of cores as double?
Also as Tim said, Hyperthreading causes some of the algorithms to jitter. Is this the same if any of the above technologies are enabled?
Do any of these enabled technologies cause a multithreaded application to hang the system?
Could you please share your thoughts regarding this? I am facing a difficult bug in my application now as I have posted in “Troubleshoot System hang” post.


Please give more details, “not working” is just not enough information.


/bin/sh: sysinfo: cannot execute - No such file or directory

That means either sysinfo is not on your system, or it is not in the execute path. Try this:

find / | grep sysinfo

If it finds nothing, well, it’s not there.