Development Computer Stopped Booting - Newbie in Trouble

As it’s ON all the time - not sure when it stopped working (as it was running until reboot).
It may have been me - I’m building a new QNX station on newer hardware, so we can backup (current system has no way to create backups) - and I may have moved something?? Pretty sure I didn’t delete.

We tried a reboot when the embedded QNX build onto a CF card failed to boot.

Now, upon reboot of the development system - I see the following:
Press ESC for alternate OS.
(No S, or D, or ‘?’)
When I press ESC - nothing happens.

I finally created a working boot floppy, which loads a .boot AOK, and Fsys.

I then manually type in “Fsys.eide fsys -Ndsk0 -no=hd0. -n5=cd0. eide -a1f0 -i14”
This is what I recently captured from the /boot/build/hard.1.425 file on this system, and also reflects this systems sysinit.1 - in the #Image: /bin/Fsys.eide fsys -Ndsk0 -n0=hd0. -n5=cd0. eide -a1f0 -i14 line.
Followed by #Image: /bin/mount -p /dev/hd0.0 /dev/hd0.0t78 /.

This finds the HD and seems to correctly ID it, and the hd0.0 is now in /dev.

But, when I run ‘mount -p /dev/hd0.0’ - I get the following error:
cannot mount partition 63 (03fh) on /dev/hs0.0:
error No SPace Left on Device
disk /dev/hd0.0 has 12594960 sectors
partition (29343793…1960021297) does not fit within disk.

It DOES create a partition /dev/hd0.0t117 - which IS one of the four original partitions.
The original partitions are:
QNX Type 77 1gb
QNY Type 78 1gb (this is the active boot partition)
QNZ Type 79 11mb
nonQNX Type 117 ?

So I did a bunch of research online, then tried the following after booting with my floppy, and running Fsys.eide shown above.
fdisk /dev/hd0.0 loader (no errors, so I presume it did what it should)
try ‘mount -p /dev/hd0.0’ again - same error.
dcheck -v /dev/hd0.0 (reports disk is OK)
dinit -hb /dev/hd0.0 (no errors)
try to run chkfsys -v -f /dev/hs0.0 - reports 'can’t find device for /dev/hd0.0. nothing to check (now I’m not entirely sure I ran the Fsys.eide?).
try to mount -p /dev/hd0.0 again - same error again.

I haven’t run ‘dinit -hr /dev/hd0.0’ - manual caution using -r, and it also sounded like a fix if the filesystem MOUNT didn’t work (vs the partition mount).
I also started reading up on SPATCH - sounds scary.

Any other suggestions I can try to get this booting again?

We have no one here anymore who knows about QNX, and this is our only development system (well, the one I’m rebuilding - but it fails to create working embedded CF cards also).

Cross posted to and comp.os.qnx

Where are you located?

Let me add a little. I think it would be wrong to try and suggest ways to fix a problem for a singular development system to an admitted newbie. The result could be a permanent disaster. I think you should seek professional help. My question above is just a prelude to figuring out if there is such help nearby.

Don’t know if this applies here or not, but I remember on some of our older Qnx2 systems when the CPU battery died we would lose the CMOS settings for the hard drive, Cyl/Hd/Sect, etc, and would have to reset them to get things working again.

A reasonable point. I think because he is using QNX 4 it is unlikely. After a while most hard drives used LBA and most bios’s autoconfigured. It would also be painfully obvious since the BIOS would usually write an error message when this happened and force the user to press an F key to continue or go into the BIOS settings.