i830 driver

So I have a single board computer with an Intel Atom with built-in video support. It works flawlessly in QNX 4.25 using the i830 driver. However, I’m having trouble with it in QNX 6.3.2. The device ID isn’t listed in the /etc/system/enum/devices/graphics file, so I added an overrides file with essentially the same information as the graphics file entry for the i830, but with only one line for the device ID of a011. When the system starts, it correctly identifies the card and tries to run the devg-i830 driver, but says “mode switcher init: invalid argument.” i830 does not show up in the graphics-modes file, and thus isn’t available as a choice in phgrafx. I tried manually adding the lines to the graphics-modes file, but when I actually tried the driver photon just died. (And yes, I waited the 15 seconds to see if it would revert.) Am I just out of luck here, or is there something else I could try to make this work?


Here’s a long shot. Download i830.tar and de-archive and try this this version. Keep the old version.

Might try gma9xx

@maschoen: Thanks for the effort, but the result was the same.

@denkelly: My 6.3.2 version does not appear to have a GMA9xx driver.

Thanks anyway, guys.

-James Ingraham

Interesting. I was working on a project with a custom designed embedded system. On the first round, the i830 driver didn’t work. We got an updated one from Dennis and it worked. That’s the one I sent to you. I think it’s been since incorporated into 6.5.0. It does seem odd that it doesn’t work for you.

Yeah, I had high hoped, especially since the i830 driver in 4.25 works so well.

I had a similar problem getting a Intel Mobile 945 chip working. I found this: http://foundry27.com/sf/discussion/do/listPosts/projects.bsp/discussion.bsp.topc17654?_pagenum=2.
The modified i830 driver works for my video chip.
Maybe it will work for you too.