USB mouse/keyboard stops working after photon starts.


We are trying to run QNX 6.5.0 on server configuration having Intel S2600CP2 Server Motherboard.
This motherboard has Integrated Matrox* G200 2D video graphics controller.
If we boot from live dvd then keyboard and mouse stops responding once photon session starts.

On command line if I check pci listing for graphics then I get
VGA Display
VID=>102bh Matrox Graphics
PID=>522h MGA G200e pilot serverengines[SCPI]

If I check on supported hardware list in qnx site then this perticular Matrox device is not listed.

Please suggest me some way if I can start photon with some basic driver or guide me
if I can edit display configuration file manually before running photon session.


I don’t know any reason that the graphics chip would cause the keyboard to stop working.
I’m curious how you know the mouse was working before Photon starts?

When we boot from live cd an window appears asking for display setting and I can see mouse pointer.
But immediately keyboard stops working.So as you said mouse might get detected but may be not
fully functional.

I will try installing qnx on harddisk and see what happens.

SGM :slight_smile:

The evidence you describe suggests to me that the mouse never was working. What version of QNX are you booting from? I don’t think USB keyboard support on the install CD was particular good in 6.2 or 6.3.

Yes you can say that mouse was never working as system stops responding immediately after photon dialog box appears asking for display stetting.
I have tried with QNX 6.5.0.

I tried installing QNX on hard disk and installation completed without any problem.
But booting from hard disk ends in similar problem as with live cd


If it is important to have QNX run on this motherboard, there are various options. You could contact QNX if you have a support contract. Another option is to install on a different computer, and get your motherboard running as a target first. Then you can investigate more easily what is going wrong.

I have seen a similar problem on an Intel server board. It does not have a PS2 controller but Photon probes for it. It took almost a minute or so, but then suddenly mouse and keyboard worked fine and you could log in.