Erratic PS/2 mouse ph...ditto...editor (vedit,vp)

Please advice. In our old application QNX4+Photon 1.13, PIII IPC, PS/2 keyboard, PS/2 mouse:
If I ditto -k /dev/con1, then open a file for editing (vedit or vp) and move the mouse, the editor('s cursor) starts to behave erratic - various random scrolls, random opening menus… ditto window even “hangs” if I move the mouse for a while longer.
If I close (even frozen) ditto window, everything works OK. If I return to that console (ditto), I see frozen editor.

Tried another (new) mouse, keyboard, various BIOS settings…

Graphics is integrated in Intel 915 chipset 8086/1132 - Pg.i810.

There’s an old joke, a man goes to the doctor. He says doc, when move my hand this way, it hurts.
The doctor asks, when you move it this way this way without it hurting? Yes. Can you move it that way without it hurting? Yes? But when you move it this way it hurts? Yes. Ok, the doctor says, don’t do that anymore.

You are using a previous incarnation of QNX (QNX 4) with an out of date version of Photon (1.13) with hardware that support that came as end of life (USB keyboard + mouse) with a specific piece of software (vedit or vp) that never integrated the mouse (as far as I can remember) very well. I don’t think you can expect any software updates fix.

I’m also a little confused about why you are ditto’ing /dev/con1 from Photon to edit a file. Wouldn’t it make more sense to use Vedit in a pterm window?

And BTW, have you tried the old QNX editor qed?

I hope someone has a better answer than this.

Well, I’ve never faced that problem (even with similar old-fashioned SW and HW) so I thought there may be QNX4 user who already seen that and knows how to solve (some BIOS Setup issue or some QNX4 configuration or… I don’t know).

You know, you should service even old apps if you are serious to your customers.

If I had no reason to do ditto -k /dev/con1 I wouldn’t do that (I admit that the reason is also kind of old-fashioned).

I don’t think it is a bug of vedit or vp. I think it has something to do with graphic and or mouse/keyboard “drivers” and maybe some memory address/IRQ conflict or so.

Hmmm, well I once ran into a processor that could run in a high level mode, outside the control of the OS. This came up because the user put the graphics card into a non-native graphics mode. This high level mode was being entered to emulate the graphics mode. It too caused erratic behavior in a driver. It effectively neutered a real time OS by creating non-realtime hardware. The cpu was an integrated x86 chip that was not made by Intel.

Is it possible you are running something like this?

So after comparing the old harddisk with older QNX4 (with no problems with Photon ditto editing files with vedit/vp) and experimenting I’ve found the solution:

In /etc/config/trap you should delete file[s]
which are created when installing QNX (maybe from some version of QNX4).
It seems input.n is “activating” also PS/2 mouse in text mode and thus conflicting with Photon mouse in ditto?

After deleting them (moving to Backup directory) and restarting PC everything works OK.

Thank you for posting the solution.
There is nothing more frustrating than someone posting a problem, then posting they have a solution without letting us know the solution.

Really,what about underwear getting stuck in your butt crack.