QNX Momentics compatibility


Is it possible to use QNX Momentics 6.2.1 (or) 6.3.0 with QNX RTOS 6.2.0.


What i have meant is, can QNX Momentics 6.2.1 or 6.3.0 be used for developing applications, for QNX RTOS 6.2.0?


It you are asking whether a QNX 6.2.1 or 6.3.0 compiled module will run under 6.2.0, the answer is maybe.

If you can recompile on the newer system, then there should be no problem.

hi Maschoen

Does it mean, QNX MOMENTICS 6.2.1 will not be compatible with QNX RTOS 6.2.0.


So I think we have a vocabulary problem here. QNX, QNX RTOS, and QNX MOMENTICS are often (and maybe incorrectly) used interchangeably to refer to the OS. When you add “Momentics” you might be referring to the development environment provided by Eclipse. Back at version 6.2.1 this could run on Windows, Linux or QNX, while doesn’t work under QNX for version 6.4 on.

With this in mind, could you be specific about what you mean by QNX Momentics 6.2.1 compatibility with QNX RTOS 6.2.0?


I have a application developed on QNX RTOS 6.2.0. For unit testing we have decided to use vectorcast, which requires QNX Momentics IDE. I have a license for QNX 6.3.0, but that seems to be no good(due to the lib changes). If i purchase a QNX Momentics 6.2.1 IDE, will it be compatible?


What is vectorcast? Why does it require the IDE. Why do you need this to test a program? Can’t you just run the program?

What does “no good(due to the lib changes)” mean? The program you compiled under 6.2.0 won’t run because it requires 6.2.0 libraries? So why not recompile it for 6.3.0? If you can’t recompile it, what does that mean? You don’t have the source?

And again, what do you mean by compatible?

I’d like to help, but none of this makes any sense to me. I’ll state some things that might be helpful if what you are trying to do is rational.

If you develop (and compile) a program under 6.2.0, you can run it under 6.2.1 or 6.3.0. This might require you to do:

  1. Nothing
  2. copy over a 6.2.0 ?.so library
  3. recompilation

This has very little to do with whether you are using the IDE to test. Testing occurs on the target system, not the host, so the library issue has to do with what is on the target.

6.2.1 is an upgrade to 6.2.0, so the question really is why you do not have it yet. 6.2.1 will be compatible with 6.2.0, for the changes read the release notes of 6.2.1. A recompile might be necessary but should be straight-forward.

Are you maintaining an old project or why this old version? It seems odd that you start unit testing now. Trying to find a nasty bug in your code?

If Vectorcast comes as an Eclipse plugin, you better verify the Eclipse version is compatible. If possible, move to QNX 6.5 SP1 to get the latest and greatest.