How can I unpack an unexpected .tarx file?

How can I extract a .tarx archive?

From QNX 4 - Other Updates, I clicked Watcom 10.6 Compiler, and then downloaded this 7MB archive of HTML files: Watcom Documentation 10.6.

I believe .tarx was introduced in QNX6, but the QNX4 page directed me to it. The Install Notes only mention tar.F files. I can melt those, no problem. But none of tar, pax, gzip or melt have any affect on .tarx.

This is rather curious. The QNX 6 documentation describes a utility qinst. When I ran qinst against the file, it comes back with “Incompatible file”. I’ll inquire further.

I did a little research. Here’s the story.
You need to run pkginstall. I’ve only found this program on the install CD.
It will install the .tarx package, but only if you have the appropriate license installed on your machine, which in this case is probably just the Watcom 10.6 license.

I tried installing it myself, but found pkginstall refused, not because I didn’t have the license, but because it was already installed.

Well surprise, surprise, it turns out that very archive is on the CD and it’s already installed on my system too. If I knew about the /usr/help/product directory I totally forgot about it.


It is strange that it’s up there as a download. What use is it if you need the CD for the install program, but which already has the archive.