qnx 6.4.1 usb driver


I’m using i.MX51 EVK BSP (processor i.MX51, QNX 6.4.1/6.5.0).
I have problem when I’m using usb driver.
My bsp support only EHCI interface.
The problem is that the system “see” usb devices like: pendrive (Verbatim chip -
I can mount file system etc.) but doesn’t see anythink when I connect USB hub.
It is very strange because I see a correct usb signals on D+/D-,
so i think that maybe it is associated with the driver.

thanks for help

There may well be a problem with the QNX USB driver, however here’s a situation that I ran into.

A customer of mine had a USB scale that worked fine when plugged into our motherboard.
When we ran it through a hub, it no longer worked.
The problem was related to the scale being USB 1.1 and the hub USB 2.0.
There was a bug in scale USB firmware that was unfixable.

So I would try other devices to make sure the problem isn’t in your device.

Thanks for help,

I forgot to mention that I’m working on my custom device.
I tested driver on the freescale evaluation board and the driver see usb hub so I think the problem is on the hardware side.

One more time thanks for help.