cpu start failure message on bootup


I am trying to run QNX nutrino 6.5 on an system having multicore processor(6 CPU core).
When I choose to boot from bootable QNX CD it gives message as
Booting QNX SDP …
…CPU 3 start failure.

In the same hardware WINDOWS7 and Ubuntu works well.
I have tested processor cores in windows/linux by enabling/disabling no of cores in bios.

Please help me resolve this problem.
I am not sure what this message means.CPU number changes on each try.

SGM :imp:

If you haven’t already, I’d try using the non-multi-core kernel. If that works, you will probably have to contact QNX about the problem. You could also take a look and see if there are any BIOS options that might help.

Try to disable hyper-threading.


I have tried disabling CPU turbo-boost and intel hyper-threading.
In bios it allows to enable no of cores to be used like 1/2/3/4/5/6.
With this if I enable only one core then it waits with following message and then pc restarts.
Booting QNX SDP …

I will try more options in BIOS.


In this situation I would use a different machine to install QNX to an HD, then move the HD over to the other machine. Before or after this (depending if booting now works), I recommend to install SP1, and after this, the latest startup code from here:

community.qnx.com/sf/wiki/do/vie … ki/X86Bios

With this installed, you could try using startup-apic instead of startup-bios, but you then also need to use pci-bios-v2 as your PCI server.


Somehow I managed to install QNX 6.5.0 after disabling
following features in bios. :slight_smile:

Enhanced Intel SpeedStep(R) Tech [Disabled]
Intel (R) Turbo Boost Technology [Disabled]
Intel (R) Hyper-Threading Tech [Disables]
Active Processor Cores [1]

Now I want to use startup-apic instead of startup-bios in build file. and

It will be helpful If anyone can guide me how to do this and update image.


Take a look in the /boot/build directory for boot image examples.

You will run the mkifs against one of these files or a modified version to create an image file.

You copy the image file to /.boot.

It’s always good to copy the current running /.boot file to /.altboot before testing a new one.
You can cause /.altboot to be used at startup by pressing ESC at the right moment.
At least that’s the way the QNX4 file system works. If you are using the QNX6 file system,
I think you can choose between files in the /.boot directory.


I found detailed help from following link.
qnx.com/developers/articles/ … 310_3.html
qnx.com/developers/articles/ … 311_3.html

I tried replacing image generated using qnxbasesmp-apic.build file and copied .ifs file to /.altboot
But no luck.

I will post detailed error message generated after trying several other options.



Finally with bios update cpu-startup failure message disappeared.
While testing after bios update I have enables all processor related features in bios.
But now after installing QNX 6.5.0 it gives following error irrespective of whether i press spacebard or d to enter debug option.

Qnx v1.2b Bootloader! qnxbasesmp.ifs…
Press the spacebar to input boot option or D to Disable DMA

Trying SATA AHCI. Scanning for devices…
Shutdown [0,0] S/C/F=1/11/1 C/D=f001c5f0/foo9cehd
state(c00)=now lock
QNX version 6.5.0 Release 2010/7/09-14:44:03EDT
[0] PID-TID=1-1? P/T FL=00019001/08000000 “proc/boot/proconto-smp-instr”
[0] ASPACE PID=4101 PF=00021010 “proc/boot/io-usb”
[1] PID-TID=1-2? P/T FL=00019001/08000000 “proc/boot/proconto-smp-instr”

[8] PID-TID=1-8? P/T FL=00019001/08000000 “proc/boot/proconto-smp-instr”
[9] PID-TID=1-9? P/T FL=00019001/08000000 “proc/boot/io-hid”

[11] PID-TID=4104-1?P/T FL=00000010/80000000 “proc/boot/devb-ahci”

and then big listing with some address/flag and some junk.

Same installation if we select qnxbase.ifs then boots in command line using debug option selection.
If I try to start photon GUI then login screen appears but usb keyboard/mouse is not working.
But this is of no use this only detects one core.

There is some info on this kernel dump understanding given at
qnx.com/developers/docs/6.3. … _dump.html

But this hardly helps.

I tried updating qnx 6.5.0 with SP1 but with this same error comes.Even qnxbasesmp-apic.ifs did not help.

I am not sure what can be done next to solve this.