Vmware image needed to unpack .z files

Hi I’ve got loads of .z files from a QNX system.
I’ve got a public .z file so one can test how I can unpack it. If there is a program available on for example Centos then I’d happy to try it.

Can someone provide please a VMWare image so i can unpack the files?

I’ve tried the latest QNX RTOS but the unpack command isn’t known.

Just out of curiosity, which version of QNX do these come from?

Hi, I’m not sure :slight_smile:.

I just saw a similar topic so I just posted it here. Is there a way to find it out?
I’ve added the link to a sample file so one of you bright guys can take a look if needed.

I tried to reply on this topic, but it isn’t being accepted.

I’m not sure which version it’s, but I’ve seen a similar topic (link is posted). And I’ve linked a file so with the .z extension so one can try out.

If you have a running QNX system and you can get to a shell ($ prompt) here’s how to find out.

$ tsk
If this works, you are running QNX 2

$ sin
If this works, you are running QNX 4

$ pidin
If this works, you are running QNX 6

I don’t know what you mean by “reply”. You can’t add to the discussion by sending an email. You have to go to the site. Also, your first few posts need approval to prevent spammers. I think you have reached your limit now and can freely post.

I don’t have a QNX system. I’ve got these files from an old CD backup.

I just need the content. I tried unpacking these with the QNX RTOS 6.x but it doesn’t have the unpack command.

I checked. Unpack is a QNX 2 command.

To unpack the files you will need a QNX 2 system of some kind. Transfering files to and from QNX 2 is possible, but a little awkward today. If the files are small enough, the dfs (Dos File System) command will let you move files on 1.44Meg floppies. For bigger files, there are other options.

I don’t know any other way to do this, but there may be.

To get a VMWare image of QNX 2 you will probably need installation diskettes.

Thanks for the info.

The problem is getting a QNX 2 system up and running. I’ve seen people getting it work on a VMWare. Is there a possibility someone can share his/her VMWare image?

I don’t have the floppy disks and also have a modern system with no floppy drive.

Even with a QNX 2 VM, you would have an additional problem. How would you get the files from the CD to the QNX system? QNX 2 cannot read a CD. There are people who read this board who you could hire to do the conversion if it is important enough. I’d suggest that you make an offer.

zip drive is another option if you still have it. I still have old qnx2 box with cdrom and floppy etc… I haven’t boot it for a long time so I don’t know if it’ll boot anymore (since I haven’t supported our legacy system for a while now) but if you send me the .z file I can uncompress it and send it back to you.

oh, I should have seen it. The link was already there. I’ll download it and try it.


@mashoen: I’d gladly pay someone, but then I’d do a lot more. I probably want someone within The Netherlands so he can unzip/extract 12gb of data for me :slight_smile:.

Seems very interesting. A QNX 2 system that generated 12gb of data. I don’t think a QNX 2 file could hold more than 32Meg.

hmm 12GB of data could not have been all created in QNX 2 system. The biggest disk I’ve used was either 256Mb or 512Mb, I can’t remember exactly. Shazada, do you have multiple .z files? or is this one big .z file? If this is a multiple .z files, what is the biggest .z file you have?