Unable to boot QNX 6.5.0 on Beaglebone black board.

Hi There,

I have downloaded QNX 6.5.0 starter kit BSP (bsp-nto650-ti-am335x-starter-kit-trunk-201307050950) imported in IDE, and built image from the source (haven’t made any change in build script or code), image gets build successfully.

But when I copy newly built image on SD card and try to boot on beaglebone black board it fails with below error…

I followed this http://www.qnx.com/developers/docs/6.5.0/topic/com.qnx.doc.neutrino_technotes/proc_dump.html?cp=13_10_8 to understand what’s the problem, and it seems that there is segmentation violation.

I don’t have much experience in kernel debugging, so
Can anyone please help me to understand what’s going wrong here? and how to solve this problem?

Please Note: Using prebuilt image file which comes with BSP package, I am able to boot.

Please help! I am fighting with this issue for last 3-4 days…

Why are you trying to boot the “starter-kit” bsp on BBB when there is a specific bsp for BBB?

Thanks for your reply.

I tried using pre-built image which comes with specific BSP for BBB but for some reason it didn’t boot. When I tried with starter kit pre-built image, it worked, so I decided to go with starter kit BSP.

But when I am building image from starter kit BSP (simply by importing BSP in IDE and building without any change) it is not working, that’s why I wanted to know whether I am missing some steps to build image.
I thought, if I am not making any change in code or config then it should work (similar to pre-built image).