realtek 8169 on QNX632


in short: please can someone help me use/load the realtek 8169 nw card on to Qnx632? I’ve got the driver handy but I failed to load it against io-net.

here’s why:
Circumstances at work are forcing me to deploy an old version (v4) of one of my apps on to Qnx632 OS. v4 leverages a bug in Qnet (the not having to respond to open connection requests on Qnet) and so v4 won’t work on a later OS, so I’m stuck with 632.

Due to having to use another expensive card in the PC I’ve been asked to set up a dual boot, offering both v5 on qnx641 and v4 on 632. The dual boot appears to work but I’ve been forced to add another nw card (realtek 8139 100Mb card) to get comms up on 632. If I can get the 1Gb card working then I’m happy. Incidentally, the reason why I’m not using both nw cards on 641 is that Qnets not configured correctly, fixing this is probably my next option but it seems clunky when all I really want it a working 1Gb nw card.

All help and ideas greatly appreciated. Thanks

According to this link: … earch.html

When I select 6.3.2 and scroll down the Realtek I see

Realtek RT8139A/B/C 10ec: 8139 ARM, MIPS, PPC, X86 PCI
Realtek RT8139 A/B/C 10ec: 8029 ARM, MIPS, PPC, SH4, X86 PCI

I don’t see any support for 8169.

Now you are saying you have the file but that’s from 6.4+. It’s not likely to work under 6.3.2. I suspect you need to obtain the source code for this driver and compile it under 6.3.2 for it to work (this will involve making it work with io-net since it’s designed to work with io-pkt).

Out of curiosity, what error are you seeing when you try to start that driver with IO-Net?


(from memory) “can’t find devn-rtl8169”, I tried absolute paths as well but with no luck. I know the card’s not supported but I read in a thread somewhere that someone had gotten the card working, and they posted the driver in the thread, so I thought I’d give it a go.

I think I’m going to get an intel gigabit card that 632 recognizes and just not tell anyone I’ve swapped the realtek one out :slight_smile:

I’m under the impression that devnp drivers work with io-pkt and devn driver work with io-net. There’s forward compatibility, so a devn driver can work with io-pkt but not the other way around. Recompiling the io-pkt driver in 6.32 will not help. The structure of the two driver typess is somewhat different.

I only tried because I read had been superceded
I did the following:
placed the driver in /lib/dll (and chmod 775 it)

xx:/lib/dll# io-net -d rtl8169 -p tcpip xx:/lib/dll# unable to load dll devn-rtl8169: Library cannot be found xx:/lib/dll# io-net -d /lib/dll/ -p tcpip xx:/lib/dll# unable to load dll /lib/dll/ Library cannot be found

‘which’ tells me there’s no io-pkt on 632 (nor io-pkt-v4), but I might have gotten away with and io-net ?

thanks for the replies

Yes. There is no io-pkt under 632 so devnp will not work. So either use io-net + devn driver.

If this doesn’t work, there might be the possibility to run io-pkt under 632. AFAIR back then there was a prerelease of io-pkt for 632 before 6.4 came out. Maybe if you request the source for io-pkt from QNX, you can recompile it for 632. But it’s not something I would recommend…

@tb, I’m good now thanks. I bought a supported 1Gb Intel card instead. It was useful to learn the difference between the devn and the devnp drivers though (it’s probably written in the documentation in large letters somewhere…) - cheers