Mounting USB On QNX 4.25

We are trying to mount USB on QNX 4.25. The QNX4.25 system was booted via Virtual machine (Vmware). The steps we done for mounting USB Mass Storage were mentioned below.
1.Enable Removable Device → SanDisk Cruze Blade-> Connect on Vmware settings Tab.
[But a warning prompted like SanDisk Cruze Blade is of USB 2.0, but the available host controller with Vmware is USB 1.1]. We neglected the warning
2.Run the following commands mentioned in the forum
a.# io-usb &
b.# Fsys.umass fsys -l -n Direct-Access=usb; Then a new entry created on /dev as /dev/usb0
c.# usb-v ; It shows the connected USB details like Vendor, Product, Class etc. So we found that our device is successfully identified by QNX

3.Then execute the command

mount /dev/usb0 /home/mnt

But an error occured : mount() of /dev/usb0 failed :Corrupted File System
For an experiment, we try to run the following command

4.# mount –p Fatfsys /dev/usb0 /home/mnt
But again error occured : Open on Fatfsys Failed: No such file or directory. But Fatfsys is located at /bin folder.

Please help us on this issue.

is the usb device FAT or QNX formatted?


you can’t do this “mount /dev/usb0 /home/mnt” for FAT

use mount_dos /dev/usb0t6 /dos/xxx where xxx is d e f g etc.

the 6 is the partition type which will vary depending on the FAT version
the mountpoint must be under /dos/

We tried to mount USB as per the mentioned step…
#mount_dos /dev/usb0 /dos/a

But an error prompted "mount_dos: Unable to find “Fatfsys” server.
But Fatfsys is available at /bin folder. [ Only usb and usb0 devices are listed in /dev. Also /dos/b , /dos/c … /dos/g options tried]
Please help

you must start the Fatfsys process yourself

When we tried to run Fatfsys manually

cd /bin


An error prompted: “Fatfsys : Unable to install-another DOS file system may be active”.

So killed the already running DOS file system and tried mounting Fatfsys.
And now it works fine; Got usb detected in QNX 4.25 and viewed its contents

Thank you ianc for your great support.

you are most welcome! Glad I could help.