Set up issues: Network/share folder on QNX 4.25 on shared VM

Dear all,

We are trying to setup network on QNX 4.25 running on VMware.
This VMware image is shared by another team to us.

We have already referred several links and did a lot of trials, for example: … f=5&t=7799 … 2&start=15

Our major observations are:

  1. We got different IPs (which we confirmed with ifconfig -a command) on different machines. (Tried installations on a couple of machines).
  2. But the MAC address remains the same on all.
  3. Initially /etc/netstart said:
    /usr/ucb/Socket: not found
    ifconfig: socket: No such process
    As per … 2&start=15, did some trials.
  4. echo $NODE says 9
  5. Verfied that Net, Net.ether2100 are running.

Our final issue is:

  1. IP obtained in ifconfig.
  2. Ping to localhost works well.
  3. Ping to any other machine says: ping sendto host is down 100% packet loss
  4. Tried to run Socket: output is - Socket: unable to attach name: /qnx/socket

Even we tried to get a shared folder working referring the link
But it says: fs-cifs command is not found.
Could you please share your valuable thoughts on this?

Thank you for your understanding and support.

I don’t know where the different IP’s are coming from, you didn’t mention. However the duplicate MAC address is easily explained. When you copy a VMware machine, which is just a bunch of files, everything gets copied including the mac address of the virtual machine.

Every version of VMWare that I’ve used has had a way to identify when this happens and the first time I’ve run the new machine it has asked a question, Did you copy or move the VM. Depending on the answer to this question, either the mac address is changed or not.

I don’t know for sure, but I suspect that if you remove the virtual NIC and then recreated it, it might have a different mac address.

It sounds like the TCP/IP package was not installed. The QNX 4 server had three different names that I recall.
Socket and Socket were a pair. You ran either one of them, but Socklet was not the full version.
The other name came from a newer version, I think 5.0, and I think it had TCP in the name.

If you can run ifconfig and see an IP address, then the TCP/IP server must be running.
The ping to local host doesn’t tell you much. This is not going through a NIC card.
The ping to other machines might be for any number of reasons, eg.
Net and Net.xxxxx not running.
Net.xxxxx not working properly
IP not on the same network as the external NICs you are trying to ping, and no gateway define with route.
Even we tried to get a shared folder working referring the link []
But it says: fs-cifs command is not found.
Could you please share your valuable thoughts on this?
fs-cifs is a QNX 6 program.

Dear maschoen,

Thank you very much for your reply.

Please see our replies inline.

We got different IPs on different VMware installations on different machines. Actually we are testing out whether network issue gets resolved in any of the available machines.

We have tried both options - copy and move the VM. Still MAC address has not changed.

We have tried uninstalling the VMware Network Adapter VMnet1 and VMware Network Adapter VMnet8 available in Network connections tab in our host machine. Please see the screenshot attached for your reference. But we are not pretty sure on how to recreate it. By the way, just asking another dumb question. Is it same you have mentioned?

We can confirm you that Net and Net.xxxx are working in our machine. Confirmed the same using ‘ps’ command.
Not sure if it is working properly due to any other internal issues.
Still our final error remains the same, ping to external machines not working. Also output of ‘Socket’ command is ‘unable to attach name: /qnx/socket’
Could you share your valuable thoughts on this?

Okay. Let me ask you an obvious question. How to make the shared folder working in QNX4.25 working on VMware?

Thank you for your understanding and patience.

I have QNX 4 running on a VMware VM. I’ll check all the configuration details and get back to you, probably this weekend.

Here is everything that I can think of that might be of help.

In Virtual Machine settings I see:

Network Adapter Bridged (Automatic)
Device status
X Connected
X Connect at power on
X Bridged: Connected directly to the physical network

If I click on “Configure Adapters” I see the adapter listed as:
X Realtek PCI GBE Family Controller.

from “sin ver”

//1/bin/Net 4.25G
//1/bin/Net.ether2100 4.24G
//1/*/usr/ucb/Socket 4.25K

Result of “ifconfig en1”

inet netmask ffffff00 broadcast

When I first run /etc/netstart I set the gateway as follows:

/usr/ucb/route add default

I hope this helps

Dear Maschoen,

Thank you a lot for your dedicated reply.
Unfortunately, no luck again. Please see my reply inline.

This is what we also see here.

Sorry. We couldn’t find “Configure Adaptors” option anywhere.

Output of sin ver is attached as sin_ver_output

Output of ifconfig is attached as ifconfig_output
We have made a couple of new trials by also referring the link
So after rebooting our ifconfig IP changed. Please see it attached as ifconfig_reboot

Output of netstart is also attached as netstart_output

Some more files which we could find are also attached for your reference like outputs of licinfo, sin net, sin info, route add etc.
As there are more files, we are attaching as a zip file named

Again our final error remains the same - ping to other machines causes 100% packet loss and Socket: unable to attach name: /qnx/socket

I also wonder if we could mount at least a shared folder using mount_nfs command.

Thank you for your understanding and patience.


Looking at “sin ver” I see that you are running Tcpip and not Socket.

These represent different versions of The TCP/IP server.

The error message about not finding /qnx/Socket indicates a utility that is looking for Socket or Socklet.

So my conclusion is that you are running a combination of old and new TCP/IP. That probably is the root of your problem.

Okay. Thank you a lot, Maschoen for that valuable information.
We shall check how this version problem could be solved.