Unable to find bootable iso of QNX 6.6

I have received academic license for QNX 6.6, in particular, the following:

  • QNX SDK for Apps and Media Adacemic Key - single user (ONLINE) (ver. 1.0.0)
  • QNX Software Development Platform Academic Key - single user (ONLINE) (ver. 6.6.0)

In the list of products, I have:

It says that the SDP contains QNX Neutrino RTOS 6.6. Following the download link, I can see the following available for download:

  • QNX® Software Development Platform 6.6 Graphics Patch [Patch ID 3875]
  • QNX® Software Development Platform 6.6 Header Files Patch [Patch ID 3851]
  • QNX® Software Development Platform 6.6.0 – Full Installation DVD [All hosts]
  • QNX® Software Development Platform 6.6.0 – Linux Hosts
  • QNX® Software Development Platform 6.6.0 – Windows Hosts

From these, only the third one (Full Installation DVD) is actually an .iso file. I downloaded it and tried booting with virtualbox but the .iso image doesn’t seem to be bootable. I have tried booting a QNX 6.4 .iso image in virtualbox and there is no problem booting (except I don’t have a license for it), so the problem doesn’t seem to be with virtualbox.

Can somebody please let me know how the heck I am supposed to install QNX 6.6?

First you install the Software Development Platform on either Windows or Linux.

Then using that development platform you create a QNX boot image (read the doc’s on it). That boot image is what you transfer to your virtualbox / hardware.

QNX 6.6 is the first version of the O/S to do things this way. Unfortunately it’s neither intuitive or easy. It’s too bad you can’t use 6.5 or earlier.


A few points to think about.

There is a 6.6 VMWare VM online that you can download. It does not have a development system, but it can be used to create a QNX format disk or image. This is very important as I will explain.

Development from 6.6 must be done via Momentics, from Windows or Linux. QNX 6.6 native has no GUI, no compiler or tool chain (at least not one available to users). Most noteworthy, QNX does not provide a direct way to format a QNX file system using Momentics.

If using VMWare is not an option, I was advised that the following could work. Build an installation system on some media, eg. flash drive using a DOS formatted partition. The boot file needs an option that I do not remember that tells the file system to treat all files on this partition as executable. Without this, you won’t be able to run any of the utilities which you will need to use to format the QNX disk.

Is there a bootable ISO file for VxWorks, Integrity, or Nucleus? I guess not! How are those being installed then? Impossible? Surely not! :slight_smile:

It’s not impossible to create a 6.6 target system. It’s just amazingly more difficult than a 6.5 one.

Would I be right to imagine that it is possible to install a GUI and a compiler? I just read that QNX doesn’t use a package manager anymore, though.

It’s possible. However you need to:

  1. obtain the source code for the compiler and GUI you want to use.
  2. Using Momentics (QNX development kit under Windows/Linux) you have to compile that code into QNX binaries / libraries.
  3. Install those on your QNX system.

I’d imagine that’s a few hundred hours worth of work depending on how difficult it is to compile the Compiler and GUI you select into something you install on QNX.


I guess I’d just learn to cross-compile my autotools-enabled libraries (1) and run the tests manually on QNX. Thanks for your help.

(1) No, I don’t care for another IDE or whatever (Momentics). I’ll just extract the tools/libraries out of it.

You can do this from the command line, once you have installed QNX SDP. No need to use the Momentics IDE, although debugger and especially System Profiler can be very helpful. As a target, I’d suggest using the ISO provided on the QNX website, it installs well in VMware and Virtual Box. That should be sufficient for your needs.