Os image qnx 6.5


I want to rebuild my ifs with associated build file, when Build it with QNX System Builder and I replace the old ifs it doesn’t work.

I have this in putty

CPU1: L1 Icache: 1024x32
CPU1: L1 Dcache: 1024x32 WB
CPU1: VFP-d32 FPSID=41033094
CPU1: NEON MVFR0=10110222 MVFR1=01111111
CPU1: 412fc09a: Cortex A9 MPCore rev 10 792MHz
cpu_startnext: cpu1 → fc409c1c

System page at phys:10017000 user:fc408000 kern:fc408000
Starting next program at vfe0520ac
cpu_startnext: cpu0 → fe0520ac
switch console to /dev/ser1

Shutdown[0,0] S/C/F=11/1/11 C/D=fe02769c/fe0a8000 state(c00)= now lock
QNX Version 6.5.0 Release 2010/07/09-14:27:56EDT
[0]PID-TID=1-12? P/T FL=00019001/05020000 “proc/boot/procnto-smp-instr”
[0]ASPACE PID=2 PF=00008012
[1]PID-TID=1-2? P/T FL=00019001/09000000 “proc/boot/procnto-smp-instr”
[1]ASPACE PID=2 PF=00008012
armle context[effeaf54]:
0000: 1ff9e000 ffff2048 fffff000 00000181 effa0bf8 00000000 01000000 fc004000
0020: fc004000 01072fff 00000008 effdf47c fe0a5840 effeaf98 fe052334 fe04c498
0040: 60000013
05 30 98 e7 1c 20 94 e5 11 00 12 e3 00 70 94 15 18 00 9d 15 07 70 80 11 0c 00
0000: effeafbc e0f47000 00000000 efffc010 fffff000 003fffff 00000e6e 1ff9e000
0020: 00000000 00000007 00000040 effa0bf8 fe0a5840 01000000 00000144 efff0090
0040: 00000073 000000d2 effabdd0 fe0500b4 effa0bf8 fe050440 efffc010 fe0798b8
0060: efffc010 fe055efc 00001000 effed830 effed830 effed830 effed830 0000000▒

In my target I can’t create a file or directory in the root, How can I do for ?


I don’t see a mention which BSP you are using, but 6.5 has been superseded by 6.6 two years ago. So maybe you are trying to use a 6.6 BSP with 6.5? Make sure you have the correct version of the BSP. Also make sure you have all patches that are available - for both 6.5 and 6.6 a handful of patches have been released. Especially for 6.5, make sure you have SP1 and also the “kernel and libc patch”.

Good luck,

  • Malte

Hi Malte,

I’m unsing the correct bsp, I’m working with it since a while, in my target I have an ifs and a buildfile provided by the provider of the board, I want to customize the ifs so i tried to rebuild the ifs with QNX System Builder, when it’s built I replace the current ifs and reset the board but it doesn’t start.

Are you building “raw” or “binary” image?

Boot File : raw

so i tried to rebuild the ifs with QNX System Builder, when it’s built I replace the current ifs
Are there warnings on the console? Is the ifs you build the same size as original?

I successfullly build ifs files in the System Builder frequently.

I had a warning with “devb-sdmmc-mx6_generic” mmc card driver, but I’m using an sd card, so I deleted the driver from bin files and the line who launch this driver in the script, I just hold “devb-mmcsd-karo-tx6 mmcsd” the driver for sd card.

The size is different the original have : 3142632 bytes and the new have : 2776144 bytes

Do you understand the reason your image is nearly 400K smaller? Omitting that many files?

You can “export” the build file from System Builder project - then compare the working build file with the failing build file.

Your kernel shutdown message includes: QNX Version 6.5.0 Release 2010/07/09-14:27:56EDT

The 2010 date indicates that you do not have QNX 6.5 Service Pack 1 (SP1) installed. I’m not sure the BSP is supposed to work without SP1!