cant run app qnx4 in virtual machine o modern pc

Good morning In my work we have an application created in QNX 4 that the manufacturer (Wincor-Nixdorf) called XIIPATT said CPU is already so obsolete that we do not get spare, specifications are CPU GEODE @ 266 MHz, 32x2 PC100 RAM on an board Intel I do not see the model anywhere, as we do not get spare for that machine we want to install that application on a more modern PC or a virtual machine.

For the application to run well requires to be installed on an IDE hard disk (the app size is 600MB) requires a Sandisk Compact Flash 32MB card and a Sandisk PCMCIA PC CARD ATA 8MB and a PS / 2 keyboard if the CPU is not connected Some of the devices do not apply correctly.

I was able to make backup images of both hard disk and 32MB CF however the 8MB not because there is no reader for that type of memory and I do not know its contents.
I was able to copy the image of the hard disk in a virtual virtual box of virtual box but there is no load in the boot (attached image) which is not the same error that gives if the lack some of the cards (attached image2).

PD:Text Translate by Google

Didn’t you already post about this in another thread (I recognize your screen shot with /dev/hd2)

The virtual machine is not likely to work because the virtual machine will not be able to emulate any of the hardware you expect to have. Just to boot you need to get the CPU/Ram etc right and even after that a lot depends on what may be in the boot image (do you know what the boot image contains) or how the BIOS settings are (do you know what those are)?

If you just need a CPU you should still be able to get one. a VERY quick google search turned up the following … B00H3SBNFS … 1741841035

which I believe is your CPU.

Other parts like motherboards/RAM are often found by googling and finding places selling old equipment. I would consider that option before using a virtual machine which won’t emulate your hardware (ATA 8 MB card for instance).


Hi tim, thanks for your reply again, if I had already opened a thread on a similar topic, but with your answers I could reconfigure the setup and get the machine started and now it works correctly.

The reason of this new thread is that my boss told me to try to emulate it in a virtual machine or install it in a more current cpu, I do not understand much of QNX what I have learned on the internet this week and I do not know if QNX requires a Hardware.

The other reason why we can not buy parts by ebay or amazon is that we are in Venezuela and the government has restricted purchases in foreign currency.

Re: Venezuela - Even if you could order you couldn’t afford it with the collapse of the Bolivar unless you had US dollars.

I have no experience with QNX 4 under VMWare. My guess is some setting in VMWare isn’t right. The most likely guess is the disk emulation. QNX 4 needs an IDE disk and maybe VMWare is emulating Sata instead.

If that’s not the problem can you list what options you have set in your Virtual machine (RAM, CPU etc).

Does your machine use a floppy or CD-Rom or networking card or any other device (sound). Those will need to all be configured correctly in your virtual machine.


P.S. I can’t remember whether you can press the space bar during the boot sequence to see more options (you can in QNX 6) like debugging messages. You may want to try and see if you get any menu.

Hi daljo25, can you send me this app or your vmware image. I can help you make it work. I’ve had some experience with QNX 4 on VMWare virtual machine.

hi sieudot, i use virual box for virtual machine, you work only whit vmware? or can work whit the virtual machine in vbox?

pd: sorry for my bad english :laughing:

I am using VMware only. In VMware, I have installed QNX 4 and can run your applications.