Porting from QNX 650 to 660 - regarding qcc

If i run command “qcc -Y _cpp -v”, i get below output:

cc: looking for gcc_ntox86_cpp in /opt/qnx660/host/linux/x86/etc/qcc/gcc/4.7.3/gcc_ntox86_cpp++.conf
cc: looking for gcc_ntox86_cpp in /opt/qnx660/host/linux/x86/etc/qcc/gcc/4.7.3/gcc_ntox86_cpp.conf

Why is it llooking for 2 configuration files?
Which one will be used?

One is meant for compiling C code and the other for C++ code (if you diff them you’ll see LANGUAGE is defined a C or C++ along with other C/C++ differences).

Normally you’ll pass an option to qcc for which you want to use. Eg ‘-lang-c++’ for c++ code.


Current software compilation is with stdC++ in QNX 6.6. I’m trying to change to QNX 6.6.0 Dinkum C++. I’m facing issues with cmath.h stdlib.h header files, they are unresolved.

What are the things to take care when changing the C++ library from std C++ to Dinkum?

Thanks for the reply Tim! “qcc” is c compiler right? does it take -lang-c++ as command line option?

qcc is not a compiler. It’s just a QNX front end tool for calling a compiler (in your case gcc) and libraries (Dinkum in your case).

-lang-c++ is indeed an option to qcc (‘use qcc’ to see all options).

There is nothing special when changing to Dinkum other than specifying the option to qcc to use Dinkum. I would imagine the ‘.h’ you are having trouble with would be the same for any compiler since they are standard files…