Looking for stuff to uncompress xar file

Hello all,

I currently analyze the files from a hard drive who was originally in a 2010 Porsche Cayenne with Harman Becker PCM 3.1.
I have a folder with four files who have a xar extension, type who it seems to be archive file, but I don’t found a way to decompress them so far. I tried some software like Easy 7-zip (a tweak of 7-zip that is reported to support xar archives) and unar on Linux but with no result.

Does someone have clues to did it ?

Thanks by advance


Have you read this and tried anything from here (FileZigZag)?


Hi Tim,

I tried the methods explain in this web page (filezigzag, peazip), nothing work.
In peazip, the software says the archives are password locked, but have no password…

It wouldn’t be the least bit surprising if they are password protected. If that’s the case you probably only have 3 options:

  1. Contact Porsche and ask them for the password (which I suspect they would decline to give you without a court order)
  2. Clone the drive. Is the O/S and executables on the same drive? If so, you might try running the ‘strings’ command on the executable(s). Look for the filename in one of the strings in the executable. If you find one, then look at the other strings and hopefully one of them is the password in plain text (very likely).
  3. Clone the drive. Is the O/S and executables on the same drive? Then try and run the whole thing in a virtual machine. If you are lucky they unzip everything into Ram or a better yet a Ram disk. The other more difficult way would be to use a debugger on the executable and step through the hex code line by line until it opens the file and uses the password . This would be time consuming obviously but I remember doing things like this on the C64 back in the 80’s when I wanted to break floppy disk protection to copy games.


Hi Tim,

thanks for your help.

In my opinion, I think Porsche doesn’t know the password, but Harman (the system maker) have, but some colleagues has already took contact them but Harman hasn’t want to cooperate except if we pay for.

Unfortunenatly, I have unsoldered the Flash memories, so the system don’t function anymore, and I don’t have a working similar system for make tests.

I think this archives files belong to the functionning of the system, but I wanted to make sure of this fact.

Thanks for your help.