UEFI machine and QNX4 installation - no way?

Hello friends,

is it possible to install QNX4 on these-days machines “without” BIOS - I mean with UEFI without Setup option “Legacy BIOS” (I think this option is in UEFI Setup only if the UEFI has CSM = Compatibility Support Module)? I am trying that, there is a setting in UEFI for SATA HDD controller mode “IDE”, but installation terminates on each step of HW detection where (I think) it looks for Legacy BIOS. The first thing to terminate is “PCI BIOS” detection. Yes, you can set installation to “Diagnostic mode” and uncheck all “problematic” HW components but you need at least CD drive, HDD drive and NIC and on some of they the installation terminates too.

To be exact, installation “sees” EIDE Controller, but when launching Fsys.atapi (for CD drive and HDD), Fsys cannot see any drives.

Question #2: Which are the latest Intel mainboard chipsets, that are supported by either classic BIOS (MBR) or if they have already UEFI (GPT) - they have CSM (option “Legacy BIOS” in their Setup)?

Question #3:
Or which are the latest UEFI versions (AMI, Phenix) with CSM (“Legacy BIOS” option in their Setup)?

I am afraid that no Intel Core i3/i5/i7 machines are compatible with QNX4 OS :frowning: Am I right?

Please help.

Author of this thread: I tried installing (or booting off already QNX4 installed hard disk) QNX 4.25 on some new machines based on EFI/UEFI. Even when there are “Legacy boot” options in UEFI (e.g. HP ProDesk), installing QNX4 (or booting off already installed hard drive) hangs/crashes (SIGSEGV) on Fsys.atapi.

It seems that all UEFI machines behave that way, that QNX4’s Fsys.atapi cannot “see” any hard drives and thus cannot see even installation CD drive filesystem (installation batch ends up with popup window that “Installer needs CD drive to install QNX”).

Is there a way how to resolve that problem?

This might be a long shot but have you seen this thread on Foundry27
community.qnx.com/sf/discussion/ … post116983

and the release notes for Proc32 4.25R
community.qnx.com/sf/wiki/do/vie … sForProc32

Hopefully this is what you need


Thank you very much Tim!

We found there also “new” QNX 4.25 Patch H (2015) installation CD, which works OK on our new UEFI computer. Now I must analyze what is different (newer).

Thank you guys from QNX Community and/or foundry27 for still working on QNX 4 system.

Hello, I am the original author of this thread. Now in 2022 I have this situation:

  • HP ProDesk 400 G3 MT (UEFI Desktop PC, generation from cca 2015-2016),
  • latest QNX 4.25 Patch H (2015) installation CD.

After some time of fihghting with UEFI Setup settings now the Installation CD boots OK, graphic installer runs OK, but when the HW detection comes, it cannot detect EIDE controller (Fsys.atapi cannot “see” the disk controller, the 30 second countdown waiting for disk response expires without controller response). And thus the Installer ends with the popup “Note” window:
“This Install requires a CD Rom Drive to be defined before you can continue”
because the optical drive is SATA too.

I tried everything in UEFI Setup, tried even the Diagnostic mode of the Installator (where I can tick the Fsys.ahci detect option) but the result is always the same.

Is there any workaround (some parameters of Fsys.atapi or some UEFI Setup setting or so) to make the Installer detect the the SATA disk controller of HP ProDesk 400 G3 MT?

Thank you.

Have you tried changing the SATA mode to IDE in BIOS?

I tried (I think) everything in UEFI Setup with no success.