Communication between 2 QNX pc's

Hello, I am trying to network pc’s running the QNX os. These pc’s run an application called AutoNet. Autonet is a data acquisition program and I want to be able to retrieve data files from other Anet pc’s. They are using TCPIP over rj45 with static IP’s. I am able to connect using FTP, but the connection gets shutdown immediately. For instance I’ll type open and it says “connected”. But when I try to do a DIR command or any command I get “NOT CONNECTED” back. I then ran “DEBUG” and tried again and the response is “FTP debug”, "getreply : expecteof = 0, carryon = 1. Also, how do I find out what version of QNX I have?. I know it’s from the 1990’s. Thanks, hope someone can help me.

Get to a command line and try these commands

$ tsk info (QNX 2

$ sin info (QNX 4

$ pidin info (QNX 6

It is doubtful that you are using QNX 2 as it did not have good TCP/IP support, but it is possible. There were a few different TCP/IP solutions, one from QNX and others from independent developers.

For QNX 4,

$ sin ver

will help describe which version of the OS. Typical values are 4.23, or 4.25G

There were two main versions of TCP/IP for QNX 4.


$ sin

and look for Socket, Socklet or Tcpip running. The latter is the latest, I think version 5.0 or 5.1.

The other thing to check is that your PC doesn’t have a firewall enabled that is preventing FTP from connecting to the QNX machines (they won’t have a firewall). I’ve found that Win 10 by default prevents outgoing FTP connections that manifest in the manner you are describing.


Thanks for responding. Somehow while messing with these tonight, I saw the qnx version go by, 3.21. I still can’t get them to talk, but one thing bothers me is that when I do a TSK cmd, I don’t see the FTPd running. I do see Telnetd, Inetd, but no Ftpd. It’s in the services file and the inet.conf. I also tried to start it from the command line, but nothing happens. No there is no firewall, These are 2 Dell PII pentiums just running QNX and the Autonet data acqusition program.

QNX 3.21 is QNX 2. I know that sounds a bit strange. QNX 3 is QNX 2 running in protected mode, that’s all.

I’m stretching my memory here. TCP/IP for QNX 2 was very rudimentary and not very standard. The first version came with an expensive card that had a processor on it. Later versions supported some off the shelf 10BaseT ethernet cards. There was one provided by QNX and another from a company in Germany. Given the way QNX 2 worked and most daemons work it surprises me that there are inetd, and telnetd programs. It would seem like the lack of ftpd is our problem.

Kermit was another way used to transfer files in the days of QNX 2.

Is Kermit running or available on those machines?


Yes the Autonet manual I have calls out Quantum ARCnet card. Also NE2000 compatible and 3com 3C507. We use the NE2000 by Linksys, ethernet 16, I believe. Maybe Autonet (by nematron) adds the additional daemons and driver support. The FTPd program does exist in the cmds dir… And it is called in the services file and I believe in the Inetd.conf file. But then when I do a tsk cmd, I don’t see it running. I have heard of Kermit but not familiar. I don’t see it being refered to anywhere in the software. We have for a long time been transferring data from the QNX pc to a Windows pc running the native IIS FTP service. I thought going from QNX to QNX would have been a breeze. Just tried the version commands and it responds to the QNX2 cmd.

QNX2 to QNX2 is a breeze if you have

  1. 2 QNET cards
  2. proper arcnet connection, either an active hub or a passive hub.
  3. 2 QNX licenses

Once you have it set up, node 2 from node one looks like this:

$ ls [2]3:/

So this won’t work with what I’m using? Why don’t I see the FTPd running when I do TSK?

On a more modern unix/linux like system, the program inetd can receive connection requests and dynamically start the daemons like ftpd. I’m not so sure how the QNX 2 TCP/IP software you have works.

You can of course try starting the daemon yourself

$ ftpd &

You can see if there are any parameters this way

$ ftp ?

The ftpd daemon should not be running. It gets started by inetd when an incoming ftp request arrives. The telnetd daemon gets started in the same manner. If you see it running it means someone (likely your self) is telnetted into the machine.

Try initiating an ftp connection to the QNX2 machine. Then check with ‘tsk’ to see if inetd starts the ftpd daemon.

It’s also worth trying to manually start it as maschoen said just to see if there are any errors (wrong file permissions, missing user accounts/directories etc).


OK thanks, I won’t be able to try anything till about mid next week. I’ll post results.

I’m back

okay started FTPd with FTPd &. It now shows up in the TSK list.

Still nothing. It says “connected to …ip”, but immediately type STAT and reply is “not connected”. Also I’ve noticed that both lights on each NIC are solid on all the time. I know my crossover is good and also I’ve run the connection utility for the nics, and they send and receive just fine.

Well, there are two possibilities. Either TCP/IP is not working, or the ftpd/ftp utilities are not working. To determine which, you could write a simple client and server that uses the socket library to try to connect. If it works, you know TCP/IP is working and the problem is with the ftp utility.

If other utilities, such as telnet work, then you know it is the latter. In that case it is probably some type of configuration issue. ftp is probably going to use the qnx password file. I hope you are not trying to connect with user root. That typically is disabled with ftp.