Network problem (localhost as ip address)

Hello, I have just installed QNX Neutrino 6.5.0 and I already get an network error. It seems like that I have no ip address, I have already reinstalled the OS but the problem is still there. And with the results of ifconfig and netstat -r I don’t know where I have to start to resolve the problem.
I’m using QNX Neutrino 6.5.0 on my Desktop to connect it with my Laptop. On my Laptop I have installed the QNX Momentics IDE and I want to connect with my Desktop in order to work under a real time environment.

Looking at your screen shots, I see you have only one visible adapter, lo0, which is a local adapter at There does not seem to be a nic driver. Since you used the QNX installation disk, and it did not find any network hardware, here is what you should do.

  1. Run the “pci” command and see if it finds any network hardware.

  2. Assuming you found some hardware, use get the VID/DID (Vendor ID/Device ID). Check the QNX hardware database to see if it is listed.

If not, you need to get some supported network hardware in your machine.

If it is listed, you can try mounting the driver directly using the mount command.

What you are looking for when you run ifconfig is another network adapter, eg. en0. I’ve also seen rt0 and wm0 for different drivers. If a device is found, you can call it en0.

Thank you for your answer !
I entered the “pci | less” command and for the network adapter I got VID: 8086h (intel), DID:15a1 (Ethernet Connection (2) I218-V). I have looked after the QNX Database to check if the device is listed but I can’t find the Database. Would it be possible if I download the Driver directly and install it in QNX Neutrino ?

Well the first thing is to find out which driver you need. You could try them all one by one.

I have to say I’m beside myself on this. I just spent 5 minutes searching via google “QNX hardware Database” and also at their site. For the last 10 years there was a resource that allowed you to connect a VID/DID with a driver if it existed. I don’t know if it is gone, or buried. This is the type of shit I’ve come to expect from QNX these days. Or rather they don’t seem to give a shit about their customers. I’m going as high to the top as I can to find out what this is about. It may take a few days but I will get back to you on this.

Ok, digging further I found the database at

You can look yourself but the VID:DID you mentioned doesn’t seem to be there. Which means it’s unsupported. I’m guessing this is a NIC on the motherboard. There’s a wide variety of cards that are supported, which you can check in the database.

I just googled for that device id (15A1). Even though it claims to be Intel this link of their official hardware says it’s not theirs but a 3rd party clone. … ducts.html

But if you google this ‘intel 15a1 vendor id’ I get tons of hits that says it’s an 82544EI. That is supported on that hardware list for 6.5

Intel 82541EI Gigabit 0x8086: 0x1013, 0x1018, 0x1019, PPC, X86 Gigabit Ethernet Controller (Copper)

So you could take a chance and manually attempt to start the 82544EI driver and specify the 15a1 device id with it and see if that works.


Excellent idea with a catch. The driver probably has a list of supported VID:DID numbers. If the number is not on the list, even if the driver would work, it won’t start.

I once had this problem with a USB to serial device. Until QNX got around to giving us the source to update the VID:DID table I was able to do the following.

  1. Make a copy of the driver
  2. Search the driver for the VID:DID table
  3. Use spatch to overwrite an entry in the table with the one I wanted to work
  4. Start the modified driver

You could try this, or maybe ask QNX for the driver source.

I will give it a try as soon as I am at home.
When I want to load the driver manually is this the right command to type in ?

io-pkt-v4-hc -t tcpip &
mount -T io-pkt “”

I have send an e-mail to the QNX support I will let you know what they will answer

No quotes around the driver name needed, although that shouldn’t matter. The shell should remove them. Otherwise it looks ok.

Once you have it running properly it’s possible to include the driver name in the start of io-pkt if you want. I don’t know of any advantage or disadvantage.

The zapping the driver is a bit of a crap shoot as it presumes the driver will work with the new chip. Still it can’t hurt to try. If it does work, definitely let QNX know to update their VID:DID table in the driver. I hope they will still pay attention to this kind of feedback, though I have my doubts.

I have tried to start the driver manually but it didn’t work,

io-pkt-v4-hc -t tcpip &
mount -T io-pkt
when I tried this command I got an message error

io-pkt-v4-hc -t tcpip &
mount -T io-pkt
here I got NO message error but there was still just one visible adapter, localhost. I restarted the system but it didn’t work either.

I sent an e-mail to 5 days ago (already the third one) but they don’t respond… is that supposed to be a customer-support ?

Since the VID/DID isn’t the normal ones you are going to have to manually provide them to

See here for how to specify VID/DID … 3_12_6_118


I tried the following command:
→ io-pkt-v4 -d /lib/dll/, did=0x15a1, vid=0x8086 -v
“Unable to load devn-i82544,.so: Library cannot be found”
and this one:
→ io-pkt-v4 -t tcpip &
mount -T io-pkt-v4 /lib/dll/, did = 0x15a1, vid=0x8086
“mount: Can’t mount did=0x15a1, (type io-pkt-v4)”
“mount: Possible reason: Invalid argument”

Maybe I have downloaded and installed the wrong version of QNX ?

It doesn’t look like the wrong verison of QNX. It looks like the driver doesn’t support your hardware.

I don’t think the comma after your driver ( is right.

See the bottom of this link for sample command of passing options directly to the driver: … o-pkt.html


P.S. I just noticed you are doing it via the mount command … mount.html

The examples section in that link says:

Try (no space after comma)
mount -T io-pkt-v4 -o did = 0x15a1,vid=0x8086 /lib/dll/


I believe all spaces must be removed in the -o section :
mount -T io-pkt-v4 -o did=0x15a1,vid=0x8086 /lib/dll/

Try the e1000 driver on this page: … dUtilities

The i82544 driver does not have the latest chips.