FTDI FT230X USB to UART Chip support?

Does anyone know anything about support for FTDI FT230X USB chips? QNX 6.5 and 6.6 don’t seem to recognize them, although they are visible with the “usb” command. Funny add on, I tried this on UBUNTU with the same result.

What commands do you launch to enable them ?

I’ve tried a number of methods.

To begin with, doing nothing. This works with another FTDI chip/cable that I use.

The next attempt is to start the driver manually as:


Following this

devc-serusb -d vid=xxxx,did=xxxx

where the VID and DID are read using the “usb” command.

Finally I’ve tried

devc-serusb -d vid=xxx,did=xxx,devno=#

where devno also comes from the “usb” command. In all cases except using the alternate cable, /dev/serusb0 does not appear.

I’ve reproduced this on a bare metal 6.5 as well as VMWare hosted 6.5 and 6.6.

I found the chip to work fine under Windows 7, however when passed through to Ubuntu, it also failed to work. In the case of Ubuntu I tried initially and then after Ubuntu requested an update which completed. This seemed particularly odd since there was a manufacturer’s web page that listed Linux support specifically for the FT230X chip.

I thought I should mention that I’m no longer held back from my project as I found a different USB/serial chip to use. I don’t know if QNX cares about the 230x but it clearly is not supported in 6.5 or 6.6 at the moment.

Have you tried the following ?

devc-serusb -d vid=xxxx,did=xxx,module=ftdi

Thank you, the only part I’m not sure of is the module=ftdi. I no longer have the device.

As the FT230X chip is a FTDI one, I suppose, this is the module to use. But who knows…

List of modules can be retrieved with : devc-serusb -d query_modules

I suppose it’s possible that the driver couldn’t identify the module from the VID, DID because the chip is newer than the driver, and that it’s possible it would work if I specified the module. I think I might have tried this, but I’m not sure, so anyone else with this chip should try it.