Remote Desktop Solutions

First post here, so I’ll start with a hello.

I am here because there is a program that my work uses that was written for QNX. And the guy who wrote it has since left. There is no-one left who knows anything about QNX, and I have been left to try and get remote desktop control over this software. Somehow. So I thought this might be the place to look.

So, I don’t know very much about QNX. As in I basically know nothing. The way this software works is that when we turn on the laptop, it boots straight into our software, and we do not really have any settings, as such, to change. There really is little we can do to alter anything there. Although I do know how to open a terminal box, and I just found out today how to ask that terminal what version QNX we are using. It looks like 6.5.0.

So far, we have managed to get it running in a Virtual Machine, using VMWare Pro (16.1.0 build-17198959) on a Windows 10 Pro machine. This has allowed us to also use some windows compatible remote desktop solutions. Such as Teamviewer, VNC and Windows own remote desktop application. The problem is that in each case, when using a remote desktop application, when I click into the VM, the mouse control goes right out of the window, and I can no longer control the software. Looking for a solution to this brought me to this forum.

Does anyone have any ideas how remote control of a VM running a QNX based software is workable? We would prefer to use Windows as the base OS on the remote machine, and run the QNX software in a VM. In doing things this way, it will allow us ultimate compatibility with computers. It turns out that the QNX based software, as it is written, is not compatible with newer instances of the ruggedized laptops we tend to use. And so we cannot currently get new machines for expansion. So if we can get everything working in a VM, then we should, in theory at least, be able to pick from a much larger range of choices for future use.

I also appear to be having issues getting some job files into the VM. As the import function of our software is looking for a USB stick to lift data from, and I cannot seem to get any of my USB sticks to connect to the software through the VM, I am having some problems. But I guess that is a question better asked on the VMWare forum rather than here.

Hi xs2man,

Welcome to the Forum.

With regards to the mouse control over Remote Desktop. Have you tried another VM besides QNX just to confirm that it works properly? There are plenty of posts on the internet about this issue and it seems to be a VMWare issue. For example I searched for “remote desktop vmware mouse cursor” and found this link among several similar ones. … -p/2227175
I’d first try another VM and confirm whether it’s a QNX issue or a VMWare issue.

With regards to the USB stick, there are no VMWare tools for QNX. VM Ware tools are what gets installed on the guest OS (QNX in your case) in order to allow things like drag/drop between the host (Windows) and guest (QNX), file transfers etc. So a lot of things that you would hope / expect to have aren’t going to be there. I’ve never been able to copy files across through VMWare or get it to recognize USB drives. You have 2 options (though you can definitely try asking in a VMWare Forum). (1) FTP file transfers (2) Samba. I’ve used both and both work and Samba is probably the way you want to go if you need to map drives for an import function.

My question to you is, why are you even using QNX? If you are running it in a VM on a laptop you’ve lost all essentially all the reasons for using QNX. Do you not have the source code to just port the whole thing to Linux or Windows?


If you are using QNX 6.5 there is a chance that you are using Photon as the GUI. If you are using Photon as the GUI there is a very nice built in remote desktop solution called Phindows.

The setup requires TCP/IP enabled, inetd to be running, with the /etc/inetd.conf file with phrelay enabled. There are potentially a number of ways you could get into the system to turns these on if they are not already.

Also you need the Windows program Phindows which you can get from QNX. If you wanted the same access from a QNX system, unlikely, the program is called PhDitto.

You are welcome to contact me directly for further assistance at maschoen AT pobox DOT com.

It is possible to use a USB thumbdrive to transfer files between the Windows host and the QNX6.5.0 VM using VMware. Cumbersome in a way but it works for me.

Overall I find QNX6.5.0 works quite well under the VM.

Mounting a SAMBA drive is certainly more elegant and I do this also on my development QNX6.5.0 system so I can transfer files between it and an old QNX4 system, and old Linux system, and Windows 7 (and 10. Although 10 doesn’t really like mounting the old SAMBA file systems). I don’t see why it wouldn’t work on a QNX6.5 VM. But I think you’d need an old archive from which to build SAMBA. I think the latest releases may prove difficult to build on QNX6.5. I built mine many years ago when such things were not quite so difficult.


Sorry for the late response. I have had a rather busy week. So I’ll try to catch up and answer as I go.

Hi Tim, thanks for taking the time to answer.

I have not yet tried another OS in the VM. But yes, I was thinking the issue was with VMWare from my searching. So I may look at trying another VM Software as the next step.
As for why we are running QNX, well the simple answer is I don’t know. The software was written before I came to the company, and this is what we have now. We did get some quotes to port it to Windows, but they were coming in around $300,000. That’s too rich for my manager just now, so I have been left with trying to get this solution workable.

That sounds like an interesting solution. I wouldn’t need access from another QNX system, only windows. However, I may need access to multiple QNX systems from multiple Windows machines, although not at the same time. I am to provide field support and so may need to see, and ideally have some level of control, over these systems. And there may be a few systems running at similar times. There is unlikely to be more than a single support person at any time, but if someone does ever relieve me, then they would also need access from their computer.

I’ll try some other things first, but I may well contact you at some point for some guidance with this if the offer is still available.

Well, I did manage to get my USB drive to be recognised once in the software running in the VM. Unfortunately, I didn’t yet have the files I needed on the drive at that time. And after putting the required files on, I never got it to be recognised again. I will have to look further.

Essentially the way our systems are set-up there is virtually none of the OS viewable to us. The laptop boots straight into the software we are running, and there are only very few settings in there for the operator to use or change. Although I have had some very limited experience of opening a command window, becoming a super user, then using pfn (IIRC). It was a while ago. We had to do this to update our software before an updater was built into the software. And we haven’t used this method since.

I will hopefully have some more time to look into this later today / next week. So I’ll take on board all of your suggestions. Thanks for the warm welcome, and the help thus far.

x22man: Yes, my offer is still good.

Tim: As to the why QNX question, I helped a customer a couple of years ago. They had a custom built system with QNX 4. It was all text based programs. The owner’s brother built the system and unexpectedly passed away. The system was running on 386 hardware which was ailing.

We put it under VM running on a windows server, accessible via a terminal program. The biggest problem was converting the reports, all customized for Epson dot matrix to HP PCL laser.

While QNX has real time capabilities, there were plenty of systems build around QNX that didn’t need this feature.

I had need to use the USB thumbdrive today to transfer files from Windows to to the QNX6.5.0 system running as a VM.

I am using VMware Workstation 15 Pro.

I select from the top menu VM->Removable Media->San Disk Cruzer->Connect|dis-connect (as the case may be). I am using a common as dirt Sandisk thumbdrive using a FAT32 filesystem.

Once disconnected from the host (Win10) I can then see the thumbdrive as /fs/usb0

I copy the file from within the Pterm (a Photon terminal shell) using cp /fs/usb0/… to wherever and then repeat the VM->Removable Media to re-connect the USB back to the host (Windows).

On shutting down the QNX VM it will automagically connect back to the host.

As I implied, I am using Photon on the QNX6 VM. I can also use Phindows (a Windows application) to connect to Photon on the QNX6.5.0 VM if I want to. But there is no real need to do this in my case.