I can’t longer live :frowning:,
does anybody known how to install Apache into QNX 6.2.1 because???

I read the post and install many times different types carefully but it doesn’t work :frowning:.

When I installed e.g. Apache 1.3.27 in eeror_log i saw:
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/mod_vhost_alias.so into server: Not enough memory
and I commeneted this line and other modules was bad as well, I commented all of them :frowning: and Apache didn’t work:(.
What modules I need into QNX ???

When I downloaded Apache ver.1.3.24 and
./configure --prefix=="/usr/local/apache"
I saw in shell sth like that:
+using instalation path layout ???
Sorry but we cannot grok “./helpers/GuessOS” ← what does it mean???

and next:
+configuration for Unknown and unsupported OS platform
but in above I saw in shell
uname -r
uname -s
and etc…
what the hell is it???

plz help me

To fix the first problem : Disable PHP.
(There is a workaround, start apache with a httpd.conf without php, then change the httpd.conf to include php, and run ‘apachectl restart’.

Don’t know how to compile apache.

Whick is the basic config in httpd.conf because ‘apachectl start’ not start httpd ?

What’s in the error_log ?

The apache from the 3rd party CD (or 3rd party online repository) is a basic one and doesn’t have php stuff. ‘apachectl start’ should just work and if not, please post the error_log.

If you downloaded apache from else where, with php included, you need to do the trick as phearbear above.

just working