vnc and phinx

I have vnc server/viewer and phinx both installed. When I run vnc server from qnx I can log on from a windows machine running viewer but I just get a window filled with a dark grey color, and a cursor. It does not appear to be a terminal because there is no prompt. I thought this was because photon would not display in vnc, thus I installed phinx.I can run phinx on my qnx machine and it opens a photon looking gui in a window on my qnx desktop, but how do I get phinx to run in the vnc viewer window on my windows machine or is this even possible? I have not tried to get phinx to run in a remote xterm session yet becouase I don’t have another qnx,unix or linux machine to try it on. But I thought I read that you could run phinx in a vnc viewer window. Of course I’m not sure the vnc server is running correctly either, should I be getting a terminal window or something when I log onto a vnc session running on qnx? Any help would be great, thanks.

When you saw “filled with a dark grey color”, were you running phinx or not?

You don’t normally need phinx, vnc server/viewer can run by themselves. You should first make sure vnc works. After that, if you have a need for photon applications, you can use phinx on top of vnc.

Check the logs in your $HOME/.vnc directory to see if there are any errors.

BTW, you need to make sure you have XFree86 4.3 from