qnx 4.25 and VMware network problems!

I recently installed VMware 4 on my windows XP laptop. I tried installing QNX 4.25 as a virtual machine and the install worked fine. It detected the CDROM, floppy, NIC and everything. My problem is that I can not ping anything outside the QNX guest OS. I have seen so many post that say the networking “just works”. What am I doing wrong?


I had the same problem, and the fix I have is

when the virtual machine is up, slay the Net.ether2100 and restart it.

Thanks noc! I found that if I slay the Net.ether2100 and restart it with the same parameters as the sysinit.1 it does NOT work. If I start it with NO paramenters it works very well. So I took the parameters out of my sysinit.1 and it works great without having to slay anything!

Thanks for the tip!

noc: do you have a entry in the netmap for the node. If it doesn’t match the “real” MAC address, TCP/IP won’t work.

My MAC address in vmware keeps changing everytime I boot into VM. So the netmap is never acurate. By slaying and restarting Net.ether2100, it puts a correct entry into the in-memory netmap at least, and everything works after that.

Thanks for the hint, and I guess if I comment out the “netmap -f” line in the sysinit file, I probably don’t need to do the restart of Net.ether2100.

I wonder what makes you MAC address change. I have been using it vmware for a few months now and on 3 very different PCs and the MAC address has never changed.

The things that I can think of that may cause the MAC address change:

  1. The host machine is a laptop and moving around on different subnets with different dhcp servers.

  2. There are multiple guest OSes installed (qnx4, qnx6, windows, linux)

  3. Sometimes I have two or more guest OSes running at the same time.

Must be it.

Same here

I do that now and then as well

I think you misunderstood me. My sysinit.1 file had this from the initial install.

/bin/Net.ether2100 -l1 -p10c0 -i11 &

and I changed it to this

/bin/Net.ether2100 &

and no more problems. I no longer have to restart the Net.ether2100 driver.

Hey i had same problem and it didnt work - maybe i did something wrong ?

I have VWware 4.0.5 @ windows xp
I installed QNX 4.25SE.
After it I tryed:

  • slay Net.ether2100 then restart: Net.ether2100 &

didnt work

I replaced the line in sysinit.1 - didnt work.
I typed netmap -f after restarting Net.ether2100 - didnt work

I still can ping QNX IP - (set by default during install)
But i cannot ping any local / internet IPs eg. (my host psychics computer).

I have tryed all 3 NIC modes in VMware - bridged, NAT, host only.

Any1 can help ?

Can you describe what you network layout looks like, is there a DHCP server on the network?

Hey, anyone looking at this. I’m just so amazed. It’s 2011. I’ve been tearing my hair out trying to get bridged networking working with QNX 4 under VM player, a product that probably didn’t exist in 2004. And the answer to my problem (Remove the parameters from Net.ether2100) was the solution. What a fantastic resource we have here.

Hi everyone,
I have the same problem here. I have installed QNX 4.25 version 2011 (released recently) on VMware workstation 7.1.4.
The installation is complete successfully. But I can’t ping any thing. I have remove Net.ether2100 paramater on sysinit, and it doesn’t work. Hic.

When I type “ping x.x.x.x”, it says “ping: socket: no route to host”
When I type “netstat -rn”, it says “netstat: no namelist”
When I type “ifconfig en0 x.x.x.x” it says “ifconfig: socket: No route to host”
When I run Voyager, the Voyager echoes “Error: DNS Failure”

How can I do ?

Did you set your vm network card to bridged?

Are you using dhcp or static ip?

The first message suggests that you don’t have anything in your resolv.conf file, however
the second message suggests that you haven’t started TCP/IP at all. The default might work:


I run /etc/netstart, It says:

/usr/ucb/Socket: not found
ifconfig: socket: No such process

Did I install something wrong or missing ?

Well the first think I’d try is:

find / | grep Socket

If it’s not there either it’s been removed or never installed. The former is more likely because if it was never installed, netstart shouldn’t be there either.

Yeah, I found it in /usr/tcprt/4.25/usr/ucb, then I copied the file Socket to /usr/ucb, and ran “/etc/netstart”.
Now, I can run “ping” (my $NODE=3) , it’s ok.
But, I can’t ping another IPs. It still says “ping: sendto: No route to host”
Run “netstat -rn” >> It says “rt_tables: symbol not in namelist”
VMware Net is set to bridged.
What can I do? Do I have to config resolv.conf file?

The obvious question is are you on a 198.9.200.x network? Is there anything else on that network to ping?
resolv.conf is for name resolution so don’t worry about it until you can ping the IP’s of the world.
The netstat message looks bad. Did anything else not run when you ran /etc/netstart?
BTW: it’s more orthodox to soft link from /usr/ucb/Socket to /usr/tcprt/4.25/usr/ucb/Socket however what you did was fine. You should probably check and link all the programs in /usr/tcprt/4.25/usr/ucb to /usr/ucb and try again.

This should have been done during the install.

What´s “real” MAC address means?

I have 3 machines with vmware connect at qnx network. All qnx network have 15 nodes. Suddenly 2 of them that have vmware installed no more connect in this network. I have done the tests listed in this forum but i havent had success.