SVN client for QNX4: has anyone got it?

A quick attack on SVN failed, it did not even ./configured properly…

I need the svn - the client part (with zlib, WebDAV and SSL support) only.

I tried a while ago but gave up, quite a beast.


Is it [too] hard to port even without it’s server part?

Some slow progress to the SVN is being made: the neon v0.26.3 library is ported.

The expat library is very easy to do, nothing needs changing at all.

WOW that would be awesome to have the client cause CVS is a getting old and doesn’t seems like its short coming will be addressed any time soon.

My news
All the tests, except the four formating the int64 strings for printing, pass OK in the APR v1.2.8.

Is that enough to get SVN going? I’m currently swamp with extra work and haven’t had time to work on OW 1.6

and heres me using RCS still :slight_smile: getting APR to work over FLEET seems like a nice hack. Would be nice to have all this QNX4 porting effort somewhere useful shame … p_id=21249 seems dead since long ago.

I do not know if my current apr-13r.lib fits the SVN’s expectations, I’m still in the APR-UTIL…

I’ve made the FLEET-diff available in the blog, please have a look at it and comment.

Unfortunately - no luck without the working clib
The APR-UTIL needs int64 to manage time|date, the SVN needs APR-UTIL…

I need some advise.

int64 ouch, that can be a problem. I don’t think OW1.6 uses int64 for time. time_t is 32 bits.

Neither QNX4 itself does, that’s no problem I think…

The problem is that I can’t build the APR-UTIL library…

Have you tried the old gcc from JC? I remember it supports int64.
I was able to use it to compile openssh (requires int64) many years back.

Internally, both - the OW v1.6RC1 and the WC v11.0beta that I use - both support int64 fine.
I’m stuck with trying to obtain a clib that will “printf(”%llx", an_int64_var)" and the like properly…

A tiny step ahead…

Mario, did you get my letter? I’m ready to FTP the tarball.

Yes just haven’t taken the time to do it.

First I suggest you get OW1.5 and install that (in c:\watcom). Then what I will send you will overwrite that. (otherwise you’d have to manually setup environment variable)

So, I am supposed to cross-compile it?

/me gone downloading…

Yes I tried building on QNX4, but that would be a lot more work. One of the requirement of OW 1.6 is that you need at least 1.5 to build it ;-)

Yes, I’ve got win-OWv1.6
I’ve got your files, now I’m trying to understand what do I do next…


If anybody is interested, let me know. I got the svn client compiled for QNX 4.25 back in 2003. (This was version 0.30); later I got svn 1.0.4 compiled.
I’m in the process of compiling 1.4.2; but I still have the binaries for 0.30 and 1.0.4 for the interested.