inetd problem under QNX 621

I would like to establish a server under QNX 621.


But i did not have a /net directory. Any problems? Any other commands needed?

thx :smiley:

Im use 6.3.2, but try “mount -t io-net /lib/dll/”.

thx, i tried, but had the following errs:
Can’t mount / (type io-net)
Possible reason: Can’t access shared library.

I had another 2 PCs with QNX 621, and they can be set as servers with the inetd, and can see both under the /net on both machines. They are in the LAN. But current laptop in the WLAN. I think there should be not any problems with this situation. ??

A simple “ping x.x.x.x” get answer from another PC’s?
When check “ifconfig” can you see your WLAN card?
If your answer “no” for any question, check your WLAN driver/configuration.
If all OK, see around:

Yes to both, the laptop can log on the internet and can ping another PC in the LAN. So there should not be anyth wrong with my wireless PC card driver. Just the server setup issue. why even the /net directory didnt appear?.. Thank u.

if it fails to mount to io-net you should first check to see if you got the network card to work with io-net first. If you have you should have /dev/io-net directory with en0 file inside. Also check if you have file in your system and also check if the location of this file is listed in your LD_LIBRARY_PATH system variable. You can check this by typing “echo $LD_LIBRARY_PATH” in your console.

use ‘-T’ instead of ‘-t’.

Thx, it worked with the “-T” arg.

spread the word… spread the word ;-)

Not until this one: :laughing:

i set the user name and passwork. I tried to log onto the QNX on my WinXP machine with ftp tools. But long time no reponse. Why this happend? The two should be in our campus LAN, though the QNX and Winxp have ip as follows: 172.a.., 172.b.., a and b are not the same. Any prblems with there ip configuration? Thx.

check your gateway address (default route). At the command line, enter the following: route add default .

You can also run phlip to configure your network. It looks like some IP settings are not correct.

I configured the QNX machine to work proper under WLAN with DHCP. But it could not ping the default gateway which was assigned to the QNX machine automatically. I think that is the problem. uh?? Then should i change the default gateway? But to which one?

Thx and Happy New Year!

Not being able to ping your gateway does not mean it won´t work.
Do you have I-Net connection, for example or any other website? Even may your campus-site?
If you do, your gateway works fine. May this two networks are not supposed to be interconnectable and therefore are not routed? Or maybe
both networks are routed through the Campus-firewall which does not allow direct connections between (almost same as not routed ^^).
Even more, some WLAN´s restrict unencrypted access as ftp/pop for security reasons (WEP and no VPN or similar).
If you are able to ping your computers now (winxp → QNX or QNX → winxp), this is likely to be.
If this is fact, try installing openssh and open an sftp connection (putty, psftp, pscp…)

yey, happy new year ^^

Quite enlightful, thx, micro.
Actually, my case is just the one u mentioned: the 2 machines can ping each other, but Winxp couldnot ftp QNX. :slight_smile:

I have installed putty on Winxp. But now i am in a troube setting up the ssh service on QNX server. Googels quite a few, still not very clear. What shall i do? :question:

The ssh service should be run automatically (sshd by inetd or as standalone) after you installed the package.

There could be an easier solution, which is far beyond security. This means any person with the key to your WLAN will have access to your data-stream and your user:pass-phrase given by ftp-login: You could just try changing ftp-port from port 21 to some other port, which should then not be blocked (as long there is no packet inspeciton ^^).

Better is get the sshd running and conntect via putty/psftp (putty = ssh (secure shell), psftp = sftp (secure ftp)).
As already mentioned, sshd should be running after installation as soon as you connect to port 22.


It would also be quite useful if you installed tcpdump on your QNX machine (from the 3rd party CD which you can access online by running the package installer in photon).

Then install Wireshark/Ethereal on your windows laptop.

Run both programs (tcpdump on qnx and wireshark on windows) and then try your ftp request to the QNX machine and see if the packets are at least reaching the QNX machine. If they are not, it points to the problems Micro is describing where some router is cutting off the ftp request).

Also, if you are trying to ftp in as ‘root’ you will need to enable root ftp access (disabled by default for security reasons) under QNX in the /etc/ftpusers file.


Thx for your help, micro.
The problem was that the Winxp with the installed Putty couldnot connect to the QNX 6.3.2. So the QNX machine also needs to run the kinda “ssh” service? The QNX machine had the err: “Network Error. Connection refused!”

Btw, I just used Putty to log into a linux machine, and linux machine has the ssh service. Am i right?

Yes, on most Linux Standard Installations the OpenSSH-Server is running. The OpenSSH Package is available for QNX 6. As Tim described the easiest way to get there is to run the package installer in photon.

Thank u for ur help, Tim and micro. I got Putty and PSFTP to work properly at last. :wink:

Sorry, another problem. i wanna realize remote desktop control. I have done the following things:
Installed XWin32 on WinXP, XFree86 XServers(x86) on QNX 6.3.2.

1)#XFree86 -configure
The machine reboot and had the err: could not get charToByteConverterClass! and then got stuck there.
3)In Putty, #ph -n “ipaddr” to load Photon Windowing environment…

I have no ideas which method will work.
I appreciate your help.